Opened 3 years ago

Closed 3 years ago

#14958 closed bug (duplicate)

Month and year header dropdowns do not have labels associated

Reported by: kden Owned by:
Priority: minor Milestone: none
Component: ui.datepicker Version: 1.10.4
Keywords: Cc:
Blocked by: Blocking:

Description

Related to but not mentioned in https://bugs.jqueryui.com/ticket/9627

To be friendly to screenreaders, the month and year header dropdowns should have labels associated with them. For formatting, the labels can actually be positioned offscreen if they cause too much clutter for sighted readers. See http://webaim.org/techniques/css/invisiblecontent/

I posted an issue on StackOverflow with an attempted workaround and it's quite painful compared to inserting two labels in the datepicker itself. (http://stackoverflow.com/questions/36779100/how-can-i-add-jaws-compatible-html-form-labels-to-month-and-day-dropdowns-in-jqu)

Change History (1)

comment:1 Changed 3 years ago by Scott González

Resolution: duplicate
Status: newclosed

Duplicate of #9298.
We'll track this as part of the general accessibility ticket.

Note: See TracTickets for help on using tickets.