Opened 8 months ago

Closed 5 months ago

#14974 closed bug (fixed)

Autocomplete Remote JSONP demo doesn't support HTTPS

Reported by: tristian2 Owned by: scottgonzalez
Priority: minor Milestone: 1.12.1
Component: ui.autocomplete Version: 1.11.3
Keywords: Cc:
Blocked by: Blocking:

Description

hi there,

https://jqueryui.com/autocomplete/#remote-jsonp

the example given that connects to http://gd.geobytes.com/AutoCompleteCity doesnt work.

i fear that some folk trying to learn this feature will be confused.

many thanks

Change History (3)

comment:1 Changed 8 months ago by scottgonzalez

  • Component changed from ui.core to ui.autocomplete
  • Status changed from new to open
  • Summary changed from Autocomplete Remote JSONP datasource documentation not working to Autocomplete Remote JSONP demo doesn't support HTTPS

I would say this is a blocker, but the problem is that you're using HTTPS and we don't fully support that yet. The problem you're seeing is a mixed content error and geobytes doesn't support HTTPS.

comment:2 Changed 5 months ago by scottgonzalez

  • Milestone changed from none to 1.12.1

comment:3 Changed 5 months ago by scottgonzalez

  • Owner set to scottgonzalez
  • Resolution set to fixed
  • Status changed from open to closed

In 930934f:

Autocomplete: Change JSONP demo to use local data source

Fixes #14974

Note: See TracTickets for help on using tickets.