Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#15029 closed bug (wontfix)

Autocomplete focus in dialog

Reported by: Blipz Owned by:
Priority: blocker Milestone: none
Component: ui.autocomplete Version: 1.12.0
Keywords: Cc:
Blocked by: Blocking:

Description

When using an Autocomplete field inside a Dialog, we can encounter some strange behavior where the focus event seems to conflict with the selection.

See https://jsfiddle.net/whpwz6wm/

Steps to reproduce:

  • Click on the input field
  • Start typing "ja"
  • Select "javascript" with a mouse click (not the keyboard)

The click will not have any effect almost every time.

This problem has appeared since 1.12.0 (I guess it is related to commit 581bfb55bf4f4f614a6e0c0ac545cf1aa7d29d0a).

By the way, the documentation says:

By giving an Autocomplete field focus or entering something into it, the plugin starts searching for entries that match and displays a list of values to choose from.

but the focusing does not trigger a search (hence the forced event binding in the example).

Change History (5)

comment:1 Changed 4 years ago by Alexander Schmitz

Status: newopen

I can confirm this issue as well as it being caused by that commit. This is an ie8 specific fix so it might make the most sense to drop it rather then spend time on trying to fix IE8.

comment:2 Changed 4 years ago by Alexander Schmitz

Component: ui.coreui.autocomplete
Priority: minorblocker

comment:3 Changed 4 years ago by Scott González

Resolution: wontfix
Status: openclosed

This works fine if you don't run a search on focus. Searching on focus isn't great UX, so I'm inclined not to do anything about this. This behavior will go away in 1.13.0 anyway once that IE 8 fix is removed.

comment:5 Changed 4 years ago by Alexander Schmitz

For the record Scott and i discussed this on a call and agree this is correct

Note: See TracTickets for help on using tickets.