Opened 14 months ago

Closed 10 months ago

Last modified 10 months ago

#15084 closed bug (fixed)

Resizable - setting handles option removes previous handles

Reported by: annam Owned by: Scott González
Priority: minor Milestone: 1.12.2
Component: ui.resizable Version: 1.12.0
Keywords: regression Cc:
Blocked by: Blocking:

Description

In jquery ui 1.12.1 it seems that when reinitializing resizable or changing the "handles" setting removes the previous handles because it assumes that they will be re-added

however if you use the object notation where you define existing DOM elements for the handles, these dom elements are removed and handles disappear

here is a jsfiddle replicating the scenario : https://jsfiddle.net/annam/2cg12b1j/

change the jquery ui include to 1.11.4 to see how it worked before

thanks! Anna

Change History (3)

comment:1 Changed 14 months ago by Scott González

Keywords: regression added
Milestone: none1.12.2
Status: newopen

comment:2 Changed 10 months ago by Scott González

Resolution: fixed
Status: openclosed
Last edited 10 months ago by Ryan J Ollos (previous) (diff)

comment:3 Changed 10 months ago by Scott González

Owner: set to Scott González

In 278d1e1:

Resizable: Keep user defined handles on _setOption

Fixes #15084
Closes gh-1795

Note: See TracTickets for help on using tickets.