Opened 6 years ago

Closed 6 years ago

#15087 closed bug (duplicate)

jQuery UI Date Picker Bug 2001

Reported by: tunwin819 Owned by: tunwin819
Priority: minor Milestone: none
Component: ui.datepicker Version: 1.12.1
Keywords: Cc:
Blocked by: Blocking:

Description

When using an icon trigger, if the date is preset to a 2001 date. When changing date using the calender picker. The year field will not update.

To reproduce:

https://jqueryui.com/datepicker/#icon-trigger

  • Manually enter 10/12/2001
  • Click the calender Icon and select Oct 01 2016.
  • The date will change to 10/01/2001 instead of 10/01/2016

Change History (12)

comment:1 Changed 52 years ago by tunwin819

Status: pendingnew

comment:2 Changed 52 years ago by tunwin819

Status: pendingnew

comment:1 Changed 6 years ago by tunwin819

Preset date can be any date that is not the current year. To reproduce, select any date in the current year (2016).

comment:2 Changed 6 years ago by Scott González

Owner: set to tunwin819
Status: newpending

200 clicks later and I see no problem. Are you seeing this only in a certain browser?

comment:3 Changed 6 years ago by tunwin819

JsFiddle: http://jsfiddle.net/qnA5R/50/

Able to reproduce in Firefo an Chrome

Last edited 6 years ago by tunwin819 (previous) (diff)

comment:4 Changed 6 years ago by Scott González

Status: newpending

That's working fine for me, and the start date is outside the valid range.

comment:5 Changed 6 years ago by tunwin819

That seems to be the issue. If the start date is outside the valid range. Then when clicking the icon to open the calender, the years fail to update.

comment:6 Changed 6 years ago by Scott González

Resolution: worksforme
Status: newclosed

I've had someone else also confirm that everything is working properly for them. None of your instructions have resulted in an incorrect behavior for anyone else, so I'm going to close this ticket.

comment:7 Changed 6 years ago by tunwin819

Currently uploading a screencast that shows the bug

comment:8 Changed 6 years ago by tunwin819

Here is the video:

https://www.youtube.com/watch?v=uPtYFs8dCb8&feature=youtu.be

As you can see, when I select the date. It should change to a date in 2006. The day and month change, but the year does not.

comment:9 Changed 6 years ago by Scott González

Resolution: worksforme
Status: closedreopened

That video shows different steps than what you provided originally. This is #8873. What you're doing is selecting a date from 2001 because that's the date you started from, and you never changed what month/year you were looking at. The yearRange option has no effect on the valid date range, so when you're looking at a date that isn't within the year range, the dropdown cannot show you which year you're currently viewing.

I'm reopening just to re-close with proper metadata.

comment:10 Changed 6 years ago by Scott González

Resolution: duplicate
Status: reopenedclosed

Duplicate of #8873.

Note: See TracTickets for help on using tickets.