Opened 3 years ago

Closed 3 years ago

#15107 closed bug (duplicate)

Unexpected auto-loading attempt with URI inline GET parameters

Reported by: Jonathan Brain Owned by:
Priority: minor Milestone: none
Component: ui.tabs Version: 1.12.1
Keywords: Cc:
Blocked by: Blocking:

Description (last modified by Ryan J Ollos)

Had strange effect with TABs not working / attempting auto-loading.

For example with this URI tab worked as expected : http://ontrain.info/location/seaton

But with this URI they did not (in example issue now fixed): http://ontrain.info/?location=seaton

These are treated identically as far as the code is concerned. Stripped stuff out of site code and narrowed issue to jQueryUI tabs.

The solution found was to add the _isLocal function below.

if (jQuery.fn.tabs) {
  jQuery.ui.tabs.prototype._isLocal = function() { return true; };
  jQuery("#tabs").tabs();
}');

Looked as the jQueryUI JS code and can see the place where it is making the unexpected Ajax call, but not familiar enough with the source / not time to look further.

The accordion is working correctly, thought it might have similar issue.

Change History (2)

comment:1 Changed 3 years ago by Ryan J Ollos

Description: modified (diff)

comment:2 Changed 3 years ago by Scott González

Resolution: duplicate
Status: newclosed

Duplicate of #7822.

Note: See TracTickets for help on using tickets.