Opened 13 months ago

Closed 8 months ago

#15109 closed bug (fixed)

button: compatibility layer with checkboxradio breaking the prototype

Reported by: Bago Owned by: Alexander Schmitz
Priority: blocker Milestone: 1.12.2
Component: ui.button Version: 1.12.1
Keywords: Cc:
Blocked by: Blocking:

Description

Calling $('selector').button() on multiple mixed elements including both input-checkbox and simple a link doesn't work anymore with 1.12.

I created a simple jsbin to reproduce the issue: https://jsbin.com/ticaxovima/1/edit?html,js,console,output

Maybe the compatibility layer to call "checkboxradio" widget instead of the button widget leaves garbage in the button widget.

Change History (3)

comment:1 Changed 13 months ago by Alexander Schmitz

Owner: set to Alexander Schmitz
Status: newassigned

Hi thank you for reporting this. I can confirm the issue. The problem is the backcompat layer is only checking the first element when deciding which widget to call instead of looping over each. 2 side notes though. First backcompat layer will be removed in 1.13 and second the markup in your jsbin is not valid, an input cannot have content ( the label in your case ), but this is not causing the issue just wanted to mention.

comment:2 Changed 11 months ago by Scott González

Milestone: none1.12.2
Priority: minorblocker

comment:3 Changed 8 months ago by Scott González

Resolution: fixed
Status: assignedclosed

In abc9e7c:

Button: Fix backcompat when called on collection of mixed elements

Fixes #15109
Closes gh-1808

Note: See TracTickets for help on using tickets.