Opened 3 months ago

Closed 3 months ago

#15125 closed bug (cantfix)

datepicker.parseDate return incorrect date on Firefox (date parsed -1)

Reported by: rodriformiga Owned by: rodriformiga
Priority: minor Milestone: none
Component: ui.datepicker Version: 1.12.1
Keywords: Cc:
Blocked by: Blocking:

Description (last modified by rjollos)

By running a parse function in updated Firefox, the returned date gets the day -1. This bug has been identified only in Firefox. In Chrome and IE works perfectly. Testing with other date formats was also performed, but the problem persists. Here is an example:

Var ret = $ .datepicker.parseDate ("dd / mm / yy", "03/01/2016")
Console.log(ret);  //this return Day 02 and not Day 03

NOTE: If you use the ret.getDate () function, the returned day is correct.

Ex: https://jsfiddle.net/rodriformiga/mxhejz2h/

Change History (4)

comment:1 Changed 3 months ago by rjollos

  • Description modified (diff)

comment:2 Changed 3 months ago by scottgonzalez

  • Owner set to rodriformiga
  • Status changed from new to pending

I can't reproduce this behavior using Firefox 50.1.0 on OS X 10.12.2. Also, if ret.getDate() is returning the correct value, it sounds like the date object is correct and there's nothing we can do about this.

comment:3 Changed 3 months ago by rodriformiga

  • Status changed from pending to new

I reproduce in Firefox 50.1.0 and Firefox 47.0.1, both on Windows 8.1 x64.

comment:4 Changed 3 months ago by scottgonzalez

  • Resolution set to cantfix
  • Status changed from new to closed

I can't reproduce using Firefox 50 on Win 8.1: https://cloudup.com/cHL5OQZaMc3

Again, if ret.getDate() is returning the correct value, it sounds like the date object is correct and there's nothing we can do about this. Even though this works for me, I'm going to close as can't fix.

Note: See TracTickets for help on using tickets.