Opened 2 years ago

Closed 2 years ago

#15196 closed bug (duplicate)

Migrating to JQuery 3.0 throwing warning in JQuery UI 1.12.1 library

Reported by: suryab21 Owned by:
Priority: minor Milestone: none
Component: ui.core Version: 1.12.1
Keywords: Cc:
Blocked by: Blocking:

Description (last modified by Ryan J Ollos)

I am upgrading my JQuery library version to 3.0 using the migration tools provided in upgradation guide and the new JQuery 3.x version showing warning in JQuery UI 1.12.1 library. In the upgradation guide it is mentioned that the JQuery UI v1.12.1 is compatible with JQuery 3.x but still it is showing few error in JQuery UI library. We do not want to change the core library methods. is there any other JQuery 3.x compatible JQuery UI version available or we have to resolve those given issue in JQuery UI core library itself?

console warning for your reference:

JQMIGRATE: Migrate is installed with logging active, version 3.0.0
jquery-migrate-3.0.0.js:62 JQMIGRATE: jQuery.expr[":"] is now jQuery.expr.pseudos
jquery-migrate-3.0.0.js:64 console.trace()migrateWarn @ jquery-migrate-3.0.0.js:64Object.defineProperty.get @ jquery-migrate-3.0.0.js:75(anonymous function) @ jquery-ui.min.js:6(anonymous function) @ jquery-ui.min.js:6(anonymous function) @ jquery-ui.min.js:6
jquery-migrate-3.0.0.js:62 JQMIGRATE: jQuery.expr.filters is now jQuery.expr.pseudos
jquery-migrate-3.0.0.js:64 console.trace()migrateWarn @ jquery-migrate-3.0.0.js:64Object.defineProperty.get @ jquery-migrate-3.0.0.js:75(anonymous function) @ jquery-ui.min.js:6(anonymous function) @ jquery-ui.min.js:7(anonymous function) @ jquery-ui.min.js:6(anonymous function) @ jquery-ui.min.js:6

Change History (2)

comment:1 Changed 2 years ago by Ryan J Ollos

Description: modified (diff)

comment:2 Changed 2 years ago by Scott González

Resolution: duplicate
Status: newclosed

Duplicate of #15185.

Note: See TracTickets for help on using tickets.