Opened 4 years ago

Closed 3 years ago

#15248 closed bug (duplicate)

Disabled Selectmenus: calling refresh repeatedly makes it slower and slower

Reported by: Fearodin Owned by:
Priority: minor Milestone: none
Component: ui.selectmenu Version: 1.12.1
Keywords: Cc:
Blocked by: Blocking:

Description

Following up on case #15078:

The bug was fixed in the case above, but only for selectmenu's which are enabled.

The fix contains the creation of a new remove-eventhandler in the widget-function 'bindRemoveEvent()'.

Here the '_untrackClassesElement' - Handler is added on-remove. But the call misses the 'suppressDisabledCheck'-Flag, which makes it useless for disabled selecmenus.

Changing the Call to the following, fixes the bug:

that._on(true, $(element), {
    remove: "_untrackClassesElement"
});

Change History (1)

comment:1 Changed 3 years ago by Scott González

Component: ui.coreui.selectmenu
Resolution: duplicate
Status: newclosed

Duplicate of #15247.

Note: See TracTickets for help on using tickets.