Opened 9 months ago

Closed 5 months ago

#15301 closed feature (duplicate)

Slider should provide a way to specify arbitrary scales

Reported by: teo1978 Owned by:
Priority: minor Milestone: none
Component: ui.slider Version: 1.12.1
Keywords: Cc:
Blocked by: Blocking:

Description

I was looking at the documentation of the Slider plugin to see how you specify a scale that is not just linear between a minimum and a maximum, for example a set of contiguous intervals with different scales, or an interval with "gaps" (i.e. subitervals that cannot be selected), and to my astonishment I find out there isn't any support for such a thing whatsoever.

The ONLY kind of slider you can build is one with a linear scale, uniform between the minimum and the maximum. That's pathetic.

You should provide a way to specify a set of non-overlapping intervals (not necessarily contiguous), each with the initial and final value, each with the initial and final position of the handle in % of the total size of the slider, and optionally each with a different value of "step".

So one could build a slider that looks, for example, like this:

0--1--2--10--20--30--100--150--200

I'm really astonished that such a basic feature isn't already there. It's the bare minimum one would expect from a bloated plugin such as ui.slider.

Also it would be nice to have a built-in option for a logaritmic slider so one wouldn't have to build that from scratch.

Change History (1)

comment:1 Changed 5 months ago by Scott González

Component: ui.coreui.slider
Resolution: duplicate
Status: newclosed

Duplicate of #10737.

Note: See TracTickets for help on using tickets.