Opened 12 years ago

Closed 11 years ago

Last modified 10 years ago

#1952 closed bug (fixed)

jQuery UI errors out when downloaded with only tabs.

Reported by: peterwooley Owned by: john
Priority: major Milestone: 1.5
Component: ui.core Version: 1.2.1
Keywords: tabs, ui Cc:
Blocked by: Blocking:

Description

When you attempt to include a build of jQuery UI that was downloaded with only the 'Tabs' option selected from ui.jquery.com (after jQuery has been included, of course), this error is given in Firefox 2.0.0.9 / Windows:

(From Firebug)

$.ui[w] has no properties
http://[domainname]/scripts/jquery.ui.js
Line 8

After the error, no jQuery UI functionality appears to work in any browser and $(foo).tabs() reports that it is not a function.

If, when downloading the build, "Draggables" and "Droppables" are selected, everything works as expected, except with a considerable file size increase.

Change History (5)

comment:1 Changed 12 years ago by paul

Owner: set to john

comment:2 Changed 11 years ago by Scott González

See #2115 (closed as duplicate) for the cause of the problem.

comment:3 Changed 11 years ago by paul

Resolution: fixed
Status: newclosed

This is fixed in the new download builder, whichs is going to be release soon.

comment:4 Changed 11 years ago by (none)

Milestone: 1.2.2

Milestone 1.2.2 deleted

comment:5 Changed 10 years ago by paul

Milestone: 1.5
Note: See TracTickets for help on using tickets.