Opened 12 years ago

Closed 12 years ago

Last modified 11 years ago

#2006 closed bug (wontfix)

dragged sortables aren't brought to top

Reported by: guy.fraser Owned by:
Priority: minor Milestone:
Component: ui.core Version: 1.2.1
Keywords: sortables Cc: rdworth@…
Blocked by: Blocking:

Description

When dragging sortable items between two panels, the sortables are appearing below the panels - eg. you can see them going below the blue dashed border when dragging from non-members panel to community members panel:

http://test.adaptavist.com

Change History (3)

comment:1 Changed 12 years ago by ebartels

I've just run into this myself. The problem is from line 68 of ui.sortable.js. In order to calculate the correct offset, the sortable element has its position set to relative. Then when dragging a child element, it gets hidden underneath the other list you're trying to drag it to. The problem is only noticeable when the background or border is set to something other than transparent.

comment:2 Changed 12 years ago by paul

Resolution: wontfix
Status: newclosed

There is a appendTo option for that - it allows for attaching the cloned element to anywhere else in the DOM, so it overlays - you can also most often set the zIndex.

comment:3 Changed 11 years ago by (none)

Milestone: 1.2.2

Milestone 1.2.2 deleted

Note: See TracTickets for help on using tickets.