Opened 12 years ago

Closed 12 years ago

Last modified 11 years ago

#2126 closed bug (fixed)

autoheight: false bug in nested accordions

Reported by: Scott González Owned by: paul
Priority: major Milestone: 1.5
Component: ui.core Version: 1.2.1
Keywords: accordion Cc:
Blocked by: Blocking:

Description

With nested accordions, certain combinations of opening/closing content panes cause problems when autoheight is set to false.

See http://www.scottsplayground.com/temp/nested_accordions/ for an example with instructions on how to re-create the problem.

Attachments (1)

slideanimation.patch (507 bytes) - added by Scott González 12 years ago.

Download all attachments as: .zip

Change History (8)

comment:1 Changed 12 years ago by Scott González

This is caused by setting the height explicitly in the slide animation ($.ui.accordion.animations.slide). Looking at previous revisions, it looks like the clearStyle option used to exist to fix this problem.

comment:2 Changed 12 years ago by joern

ui.accordion.js was out-of-sync with jquery.accordion.js - I'm still maintaining both until UI gets a stable release. The clearStyle option is now also available via ui.accordion.js.

This helps with nested accordions (which were never meant to be supported), though the third issue ([IE] Open/close 1a. Notice that the nested accordion does not show/hide properly.) still remains.

comment:3 Changed 12 years ago by joern

Resolution: fixed
Status: newclosed

Fixed in [4419].

comment:4 Changed 12 years ago by Scott González

Resolution: fixed
Status: closedreopened

[4419] didn't fix the problem; I've attached a patch.

Changed 12 years ago by Scott González

Attachment: slideanimation.patch added

comment:5 Changed 12 years ago by joern

Resolution: fixed
Status: reopenedclosed

Applied the patch in [4424].

comment:6 Changed 12 years ago by (none)

Milestone: 1.2.2

Milestone 1.2.2 deleted

comment:7 Changed 11 years ago by paul

Milestone: 1.5
Note: See TracTickets for help on using tickets.