Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#2131 closed bug (notabug)

strange behavior for draggable inside fixed position parent

Reported by: Scott González Owned by: paul
Priority: major Milestone:
Component: ui.core Version: 1.2.1
Keywords: draggable Cc:
Blocked by: Blocking:

Description

When dragging an element that is inside an element that has position: fixed, there is a strange re-drawing problem for the parent element.

See http://www.scottsplayground.com/temp/drag_fixed_container/ for an example. Drag the yellow div to the left of the purple div to see the problem.

Change History (4)

comment:1 Changed 13 years ago by Scott González

Tested in Firefox, IE, Opera and Safari on Windows. The flickering only occurs in Firefox.

comment:2 Changed 13 years ago by Scott González

If using a clone or ghosting, this can be avoided by appending the helper to the body: $('#drag').draggable({

ghosting: true, appendTo: document.body

});

comment:3 Changed 13 years ago by paul

Resolution: invalid
Status: newclosed

Cannot reproduce it on FF Mac, but I can reproduce it with FF Win. This means it's definitely a rendering issue within the OS/Browser, and unfortunately unfixable for us. Thanks anyway!

comment:4 Changed 13 years ago by (none)

Milestone: 1.2.2

Milestone 1.2.2 deleted

Note: See TracTickets for help on using tickets.