Opened 13 years ago

Closed 13 years ago

Last modified 11 years ago

#2262 closed bug (wontfix)

iFrame problem while using UI Sortables makeSortable

Reported by: BNArun Owned by: codesquare
Priority: major Milestone:
Component: ui.core Version: 1.2.2
Keywords: ui sortable makeSortable Cc:
Blocked by: Blocking:

Description

I'm using new ui.sortables makeSortable method. When I'm using an iFrame in this, this iFrame is getting refreshed when dragging is started. Fortunately it is not refreshing it's contents while dragging is completed.

Change History (4)

comment:1 Changed 13 years ago by paul

Owner: changed from paul to codesquare

This is something Firefox related. I don't know why it's happening though..

comment:2 Changed 13 years ago by codesquare

Resolution: wontfix
Status: newclosed

The problem is that the drag helper is a clone of the sortable which means it has to create a new iframe (as well as all the other dom nodes) to build the sortable/draggable helper. You'll need to explore using a different helper method or building your sortables without iframes. If the iframe content is domain local you could use an ajax call to get the iframe content and inject it as static content.

comment:3 Changed 13 years ago by (none)

Milestone: 1.2.3

Milestone 1.2.3 deleted

comment:4 in reply to:  3 Changed 11 years ago by markforster

Replying to None:

Milestone 1.2.3 deleted

FYI - the problem is more likley to do with this issue logged against ,mozillas firefox

https://bugzilla.mozilla.org/show_bug.cgi?id=254144

When an iframe is removed from the DOM, its content is reloaded.

I figure the safest solution is to not change the parent i.e. not remove the element from the DOM at all although i can see this causing further css related issues re zindexing and overlfow

Note: See TracTickets for help on using tickets.