Opened 12 years ago

Closed 11 years ago

#2331 closed bug (worksforme)

Slider range: dragging range causes weird behaviour

Reported by: gregmac Owned by: rdworth
Priority: critical Milestone: 1.7
Component: ui.slider Version: 1.6rc4
Keywords: Cc:
Blocked by: Blocking:

Description

This issue can be seen on the demo @ http://dev.jquery.com/view/trunk/ui/demos/ui.slider.html

Adjust both handles so they are each about 1/3 of the way in, and then try to drag the darker area in between the two handles. The expected behaviour is that both handles move, and you are confined to the slider - eg, you are adjusting both handles at once.

What happens though is the two sliders become draggable ghosts, there is no range shown between them, and they are not confined to the slider. When you let go, the ghosts disappear and nothing else happens.

This could possibly be considered an enhancement, but definitely the slider ghosts showing up is a bug.

Change History (7)

comment:1 Changed 12 years ago by paul

Status: newassigned

Dragging the range is currently not possible. I'm working on a implementation.

comment:2 Changed 12 years ago by paul

Owner: changed from paul to braeker
Status: assignednew

comment:3 Changed 12 years ago by joern

Resolution: worksforme
Status: newclosed

Can't reproduce in latest version.

comment:4 Changed 12 years ago by (none)

Milestone: 1.2.4

Milestone 1.2.4 deleted

comment:5 Changed 11 years ago by rdworth

Component: ui.coreui.slider
Milestone: 1.6
Priority: majorcritical
Resolution: worksforme
Status: closedreopened
Version: 1.2.31.6rc4

comment:6 Changed 11 years ago by rdworth

Owner: changed from eduardo to rdworth
Status: reopenedassigned

comment:7 Changed 11 years ago by paul

Resolution: worksforme
Status: assignedclosed

Not reproducable (range is still not draggable, but the odd behaviour doesn't occur anymore -instead, the closest handle moves to the clicked position)

Note: See TracTickets for help on using tickets.