Opened 12 years ago

Closed 12 years ago

Last modified 11 years ago

#2438 closed bug (fixed)

[slider] strange behavior for wide range

Reported by: alexo Owned by: joern
Priority: major Milestone: 1.5
Component: ui.core Version: 1.2.3
Keywords: slider multiple handle Cc:
Blocked by: Blocking:

Description

For the following slider (with multiple handles), when handle values are changed, the console will output both handle values. The are at least two anomalies:
1) the steps value is ignored
2) the max handle value is not correct for the right edge case

<h2>3. Multiple handles, with range</h2>
<div class="playground">
	<div id='example3' class='ui-slider-2' style="margin: 40px;">
	<div class='ui-slider-handle'></div>
	<div class='ui-slider-handle' style="left: 188px;"></div>	
	</div>
</div>
function onChange(e, ui) {
  var el = ui.instance.element;	
  console.log(el.slider("value",0) + " - " + el.slider("value",1));
}	
$('#example3').slider({ minValue: 100, maxValue: 50000, steps: 1000, range: true, change: onChange });

Thank you!

Alex Objelean

Change History (9)

comment:1 Changed 12 years ago by paul

Owner: changed from paul to braeker

comment:2 Changed 12 years ago by joern

Owner: changed from braeker to joern

comment:3 Changed 12 years ago by joern

Actually the steps value isn't ignored. If you output the current value on the Firebug console on slide and use the keyboard to change the value, you can see that each step is 249. The result is still rather strange, not sure yet what the issue is.

comment:4 Changed 12 years ago by alexo

I would expect that each step would increment the current value with 1000 (the step value), at least this was the behaviour in jQueryUI-1.0.

comment:5 Changed 12 years ago by joern

Summary: jQueryUI Slider plugin - strange behavior for wide range[slider] strange behavior for wide range

comment:6 Changed 12 years ago by paul

Resolution: fixed
Status: newclosed

Fixed in r5539.

comment:7 Changed 12 years ago by joern

Can't confirm this as fixed.

ui/tests/uiTest.slider.html, options, slider-options-range: doesn't work at all

comment:8 Changed 12 years ago by (none)

Milestone: 1.2.4

Milestone 1.2.4 deleted

comment:9 Changed 11 years ago by paul

Milestone: 1.5
Note: See TracTickets for help on using tickets.