Opened 12 years ago

Closed 12 years ago

Last modified 11 years ago

#2441 closed bug (fixed)

'missing' over event with nested droppables

Reported by: StrikerNL Owned by: codesquare
Priority: minor Milestone: 1.5
Component: ui.core Version: 1.2.3
Keywords: droppable over event Cc:
Blocked by: Blocking:

Description

There seems to be a bug in droppable, when multiple divs are nested and droppable.

The over event for a parent droppable only gets called once; it doesn't seem to get called when one moves into a child droppable and back into the parent droppable.

The out event for the child does get called. One could, using this, keep track of the droppables that are currently in an 'over' state, and so know when the draggable has moved back into the parent droppable.

Maybe this is by design, it doesn't make for convenient coding however.

My suggestion is to either make the over event be triggered when a draggable leaves a child droppable into a parent droppable, or make it a behaviour option.

I have created a testcase which can be found at http://ddcrew-dev.be/droppable/ (also attached as droppable.zip).

The left frame shows the situation as it is now, the right frame shows how I'd prefer it to be. To test it, simply drag the draggable over the droppables and observe the 'over' and 'out' events that get called.

The code I wrote to make the 'fixed' version can be found in ui.droppable.fixed.js. I have also included a patch against jquery ui 1.5b (droppable.patch). I'm not sure if it's good enough for inclusion, someone more expert will have judge that.

Thanks for this great jquery plugin and your time!

Attachments (1)

droppable.zip (40.7 KB) - added by StrikerNL 12 years ago.
Testcase

Download all attachments as: .zip

Change History (7)

Changed 12 years ago by StrikerNL

Attachment: droppable.zip added

Testcase

comment:1 Changed 12 years ago by paul

Owner: changed from paul to StrikerNL

I cannot reproduce your issue with the test case you have on your server - can you recheck please? Both sides work exactly the same for me and report all states.

comment:2 Changed 12 years ago by StrikerNL

That is odd, what browser are you using?

When I use the left frame, dragging the purple div over the red one into the yellow one and back out again I get these events (newest first):

leaving outermost
leaving inner
moving into inner
moving into outermost

Same for the right frame:

leaving outermost
moving into outermost
leaving inner
moving into inner
moving into outermost

The missing "moving into outermost" in the left frame is what I'm talking about.

comment:3 Changed 12 years ago by paul

Owner: changed from StrikerNL to codesquare

comment:4 Changed 12 years ago by Scott González

Resolution: fixed
Status: newclosed

I think the current behavior makes sense for standard droppables. See #2571 for the commits that fixed this for greedy droppables.

If you feel that this behavior should exist for standard droppables, please reopen this ticket.

comment:5 Changed 12 years ago by (none)

Milestone: 1.2.4

Milestone 1.2.4 deleted

comment:6 Changed 11 years ago by paul

Milestone: 1.5
Note: See TracTickets for help on using tickets.