Opened 12 years ago

Closed 12 years ago

Last modified 11 years ago

#2477 closed bug (fixed)

Safari 2.0.4 and Sortables

Reported by: shelane Owned by: eduardo
Priority: major Milestone: 1.5
Component: ui.core Version: 1.2.3
Keywords: Cc:
Blocked by: Blocking:

Description

Try to drag anything and it either wants to become the first or last item leaving only a hole behind in it's place. If you do the toArray call, the order is the original order.

http://dev.jquery.com/view/trunk/ui/demos/ui.sortable.html

Attachments (1)

safari_contains_2477.diff (3.1 KB) - added by ebartels 12 years ago.
Reimpliment contains functionality to work with safari2

Download all attachments as: .zip

Change History (7)

comment:1 Changed 12 years ago by ebartels

It looks like problems are caused by the Node.contains DOM function. It's supposed to return true if one node contains another, but as far as I can tell the Safari 2 implementation is buggy and always returns true for sibling nodes. This function is used in several places within ui.sortables.js. To get Safari 2 working we're going to need an alternative way to find out if one node contains another.

Changed 12 years ago by ebartels

Attachment: safari_contains_2477.diff added

Reimpliment contains functionality to work with safari2

comment:2 Changed 12 years ago by ebartels

I'm submitting a patch to work around Safari's buggy Node.contains function. I've added a standalone function called contains. It's not as pretty, but since Safari 2 doesn't expose Node.prototype, we can't override it directly.

Tested in ie 6/7, firefox 2, opera, and safari 2/3.

comment:3 Changed 12 years ago by paul

Owner: changed from paul to braeker

comment:4 Changed 12 years ago by paul

Resolution: fixed
Status: newclosed

Fixed in r5403.

comment:5 Changed 12 years ago by (none)

Milestone: 1.2.4

Milestone 1.2.4 deleted

comment:6 Changed 11 years ago by paul

Milestone: 1.5
Note: See TracTickets for help on using tickets.