Opened 11 years ago

Closed 10 years ago

#2520 closed bug (worksforme)

[Resizable]Image move toward oppsited when mouse went out of the boundary

Reported by: zigzag.chen Owned by: eduardo
Priority: critical Milestone: 1.7
Component: ui.resizable Version: 1.5b4
Keywords: resizable image Cc:
Blocked by: Blocking:

Description

tests/resizable.html

When the mouse drag the inner frame of the puppy image and move out of the right/bottom boundary, the image in frame went left/up.

Maybe it is just a bug in the test code.

Attachments (1)

test-ui2520.html (395 bytes) - added by dmethvin 10 years ago.

Download all attachments as: .zip

Change History (10)

comment:1 Changed 11 years ago by paul

Owner: changed from paul to braeker

comment:2 Changed 11 years ago by braeker

I cant understand the problem, could you explain again? Thanks a lot.

comment:3 Changed 11 years ago by telega

I have the same problem. When an element is made both draggable & resizable, after being resized for the 1st time, element begins jumping a bit to up & left direction on any subsequent drag or resize attempt. JQuery version: 1.2.3, JQuery UI version 1.5b

Test code:

<script src="jquery-1.2.3.js"></script>
<script src="jquery.dimensions.js"></script>
<script src="ui.mouse.js"></script>
<script src="ui.draggable.js"></script>
<script src="ui.resizable.js"></script>
<script>
  $(document).ready(function() {
    $("#aaa").resizable().draggable();
  });
</script>

<style>
  #aaa {
    width: 100px;
    height: 100px;
    background-color: lightblue;
    border: 1px solid black;
  }
</style>

<div id="aaa">bbb</a>       

comment:4 Changed 11 years ago by (none)

Milestone: 1.2.4

Milestone 1.2.4 deleted

comment:5 Changed 11 years ago by paul

Component: ui.coreui.resizable
Version: 1.2.31.5b4

comment:6 Changed 11 years ago by Cloudream

Milestone: TDB

comment:7 Changed 10 years ago by Scott González

Milestone: TBD1.6
Priority: minorcritical

Changed 10 years ago by dmethvin

Attachment: test-ui2520.html added

comment:8 Changed 10 years ago by dmethvin

I don't see the behavior described--test case attached. However, I do see the resize handles disappear in IE8 beta2 after the first resize.

comment:9 Changed 10 years ago by eduardo

Resolution: worksforme
Status: newclosed

I cannot reproduce this error too.

Seeing that me and dmethvin weren't able to reproduce it I understand that this bug is not happen anymore, therefore this ticked will be closed.

Note: See TracTickets for help on using tickets.