Opened 11 years ago

Closed 11 years ago

#2566 closed enhancement (duplicate)

24 hour Time Picker Added to UI Datepicker v3.4

Reported by: jdean Owned by: grabanski
Priority: major Milestone:
Component: ui.datepicker Version: 1.5b4
Keywords: calendar date time picker Cc:
Blocked by: Blocking:

Description

For an internal project we needed a calendar with time picker as well so we have updated UI Datepicker with a 24 hour time picker.

The updated js and css files are attached if anyone wants to use them or incorporate back into a future version of UI Datepicker.

The new date format codes are

HH - Hours
II - Minutes
SS - seconds.
eg: dateFormat: 'yy-mm-dd HH:II:SS',

New parameters

showTime: true,
timePos: 'top' or 'bottom',

New class

datepicker_time

Regards
James Dean
One Reason Pty Ltd

Attachments (2)

ui.datepicker.css (4.2 KB) - added by jdean 11 years ago.
Updated ui.datepicker.css
ui.datepicker.js (68.9 KB) - added by jdean 11 years ago.
Updated ui.datepicker.js

Download all attachments as: .zip

Change History (6)

Changed 11 years ago by jdean

Attachment: ui.datepicker.css added

Updated ui.datepicker.css

Changed 11 years ago by jdean

Attachment: ui.datepicker.js added

Updated ui.datepicker.js

comment:1 Changed 11 years ago by paul

Owner: changed from paul to iMarc

comment:2 Changed 11 years ago by paul

Component: ui.coreui.datepicker
Version: 1.5b4

comment:3 Changed 11 years ago by paul

Owner: changed from iMarc to grabanski
Status: newassigned

comment:4 Changed 11 years ago by kbwood

Resolution: duplicate
Status: assignedclosed

Duplicate of #2000.

Note: See TracTickets for help on using tickets.