Opened 12 years ago

Closed 12 years ago

#2615 closed bug (notabug)

[ui.dialog] no reason for .css({position: 'relative'})

Reported by: rbuc Owned by: Scott González
Priority: minor Milestone:
Component: ui.dialog Version: 1.5b4
Keywords: Cc:
Blocked by: Blocking:

Description

I can't see the reason while the position of .ui-dialog-container must be set to relative within the script and not inside the theme css. When toggling this with firebug and I can't even see a visual difference. The problem is because it's set dynamically one can't override it with css.

line 102, rev 5143

		var uiDialogContainer = uiDialogContent.parent().addClass('ui-dialog-container').css({position: 'relative'});

Change History (4)

comment:1 Changed 12 years ago by paul

Owner: changed from paul to scott.gonzalez

comment:2 Changed 12 years ago by (none)

Milestone: 1.2.4

Milestone 1.2.4 deleted

comment:3 Changed 12 years ago by paul

Component: ui.coreui.dialog
Version: 1.2.31.5b4

comment:4 Changed 12 years ago by rdworth

Resolution: invalid
Status: newclosed

It's set inside the code because it's a reasonable default. You can override it in css with !important.

Note: See TracTickets for help on using tickets.