Opened 12 years ago

Closed 12 years ago

Last modified 10 years ago

#2753 closed bug (notabug)

jQuery UI sortables: "helper" item not visible when dragging between scrollable divs.

Reported by: wang Owned by: paul
Priority: major Milestone:
Component: ui.core Version: 1.2.3
Keywords: sortable overflow Cc:
Blocked by: Blocking:

Description

When dragging an item from one connected list to another (the lists are in separate divs), the helper item becomes invisible.

This only happens when one (or both) of the divs are scrollable ("overflow: scroll").

This has been tested on XP in IE7 and Fx2, and on Leopard in Fx3b5 and Safari 3.1. Please see attachment for an example.

Attachments (1)

disappear.html (2.6 KB) - added by wang 12 years ago.

Download all attachments as: .zip

Change History (5)

Changed 12 years ago by wang

Attachment: disappear.html added

comment:1 Changed 12 years ago by paul

Status: newassigned

comment:2 Changed 12 years ago by paul

Resolution: invalid
Status: assignedclosed

That's not a bug - it happens because the helper is appended to the parent, and therefore cannot be moved out. Try using the appendTo option to append the helper to a higher node, i.e "body"

comment:3 Changed 12 years ago by (none)

Milestone: 1.2.4

Milestone 1.2.4 deleted

comment:4 Changed 10 years ago by Hemendara

Hi

I have a similar problem. There are many lists(divs) in my page that are sortable and connected to each other and only one of them have 'overflow:auto' and when I move a element from that div(with overflow) the element doesn't seem to move above, Instead it seems to move below and gets hidden (Actually within the div it moves properly, but it disappears or gets cut when crossing the div boundary. It gives a feeling like its moving below the screen, but still I can drag and drop it in another list). I have even set zIndex as the highest. This issue happens only in IEseries browsers. Firefox and chrome seem to work fine.

One work around will be to use helper and appendTo:'body' . This workaround works good. but I don't want to use helper in certain cases. Anyother ways? As of now this work around is fine, but I would like to have a permanent solution.

Note: See TracTickets for help on using tickets.