Opened 11 years ago

Closed 11 years ago

#2763 closed bug (notabug)

[slider] opera9 click bug

Reported by: hex0id Owned by: paul
Priority: minor Milestone: 1.7
Component: ui.slider Version: 1.5b4
Keywords: slider click bug Cc:
Blocked by: Blocking:

Description

strange things happen when clicking on any place of slider (not handler) and then start drag (using handler) in opera 9. FF2, IE6-7 are ok.

jquery v1.2.3 rev4663 ui.base rev5174 ui.slider rev5219

Change History (10)

comment:1 Changed 11 years ago by paul

Owner: changed from paul to joern

comment:2 Changed 11 years ago by joern

Opera throws:

Event thread: mousemove
name: TypeError
message: Statement on line 229: Could not convert undefined or null to object
Backtrace:
Line 229 of linked script http://localhost/ui/ui.slider.js
this.handleOffset = this.currentHandle.offset();

comment:3 Changed 11 years ago by joern

Summary: ui.slider opera9 click bug[slider] opera9 click bug

comment:4 Changed 11 years ago by paul

Owner: changed from joern to paul
Status: newassigned

comment:5 Changed 11 years ago by paul

Cannot reproduce this issue with Opera 9.5 and Dragonfly. What Opera version specifically are you using?

comment:6 Changed 11 years ago by drsco

i get this same error.

Opera Version Info Version: 9.27 Build: 8841 Platform: Win32 System: Windows XP Java: Sun Java Runtime Environment version 1.6

comment:7 Changed 11 years ago by (none)

Milestone: 1.2.4

Milestone 1.2.4 deleted

comment:8 Changed 11 years ago by paul

Component: ui.coreui.slider
Version: 1.2.31.5b4

comment:9 Changed 11 years ago by paul

Priority: majorminor

It's a issue related to focussing the element - seems like a Opera bug though, trying to see what I can do.

comment:10 Changed 11 years ago by Cloudream

Milestone: 1.6
Resolution: invalid
Status: assignedclosed

OK in Opera 9.51

Note: See TracTickets for help on using tickets.