Opened 12 years ago

Closed 12 years ago

#2792 closed bug (worksforme)

accordion right span not inserting correct

Reported by: sosensible Owned by: joern
Priority: minor Milestone:
Component: ui.accordion Version: 1.5b4
Keywords: accordion Cc:
Blocked by: Blocking:

Description

The right accordion span is inserting inside the <a/> tag but the left is working correctly and puts the span before the <a/> set. (Same in IE and FF on Vista)

Change History (8)

comment:1 Changed 12 years ago by joern

Resolution: invalid
Status: newclosed

That isn't an error, but required for themeing with CSS. See http://dev.jquery.com/view/trunk/themes/flora/flora.accordion.css for reference theme.

comment:2 Changed 12 years ago by sosensible

Resolution: invalid
Status: closedreopened

Note: it was putting tags like this...

<span class="ui-accordion-left"/>
<span class="ui-accordion-left"/>
<a class="ui-accordion-link ui-accordion-header selected" href="#" tabindex="0">
Test 1
<span class="ui-accordion-right"/>
<span class="ui-accordion-right"/>
</a>


There were even some cases where I have seen three tag sets. The leading (left) doesn't visually appear to show either to us.



OK... it may not be an error but in FF it sticks the accordion-right in the upper right corner of the browser. And the left as I said is just not visible.

IT'S broke! :) I am online now at least if screen sharing to see the issue is helpful.

comment:3 Changed 12 years ago by sosensible

It's worse in IE BTW... IE shows an extra line with each accordion title bar.

comment:4 Changed 12 years ago by sosensible

You "DELETED" my issue?

comment:5 Changed 12 years ago by paul

Owner: changed from paul to joern
Priority: majorminor
Status: reopenednew

comment:6 Changed 12 years ago by (none)

Milestone: 1.2.4

Milestone 1.2.4 deleted

comment:7 Changed 12 years ago by paul

Component: ui.coreui.accordion
Version: 1.2.31.5b4

comment:8 Changed 12 years ago by Scott González

Resolution: worksforme
Status: newclosed

I haven't seen this problem. If you're able to create a test page that you can attach, then feel free to re-open this ticket again.

Note: See TracTickets for help on using tickets.