Opened 12 years ago

Closed 9 years ago

Last modified 9 years ago

#2942 closed bug (fixed)

ui Accordion testing Safari and Firefox

Reported by: tim@… Owned by: Jörn Zaefferer
Priority: major Milestone: 1.8.2
Component: ui.accordion Version: 1.5rc1
Keywords: Cc:
Blocked by: Blocking:

Description

hi, 3 issues:

  1. Firefox, opening the top tab will blow out the containing tab. Minimising either tab adds scrollbars to the drawer. (Firefox 2.0.0.14 OS X)

Test here: http://www.boxc.net/index_jquerytest.html vs. http://www.boxc.net/index.html (using accordion plugin)

  1. Safari, I can't explain this. If you add #TARGET to the URL, which is the id in the second accordion tab, the second tab will be raised above the first tab:

http://www.boxc.net/index_jquerytest.html#pro (Safari 3.1.1 OS X)

  1. Safari I had code in before to open the accordion based on #TARGET in the location. I changed this to ?TARGET because of the above issue. It works most of the time. but occasionally Safari will only half open the tab:

http://www.boxc.net/index_jquerytest.html?pro (Safari 3.1.1 OS X) Note: this is difficult to reproduce i.e. behaves inconsistently. Test here: http://www.boxc.net/index_jquerytest.html

My apologies if this is my code which is causing these issues

Change History (7)

comment:1 Changed 12 years ago by heyyeah

Please disregard or lower priority of item 3). It was hard to reproduce and I realise I was going about it the wrong way in my code. I fixed my code to use addClass to set an active tab rather than try to activate the active tab during page set up.

If you want to see item 3) I have preserved the test codewith my old logic at: http://www.boxc.net/index_jquerytest.html vs. http://www.boxc.net/index_jquerytest2.html (acccordion plugin)

The first 2 items are still bugs I think? Again, my apologies if it is my code causing these issues.

comment:2 Changed 11 years ago by rdworth

Milestone: 1.51.5.2

comment:3 Changed 11 years ago by paul

Milestone: 1.5.21.6b

comment:4 Changed 11 years ago by Cloudream

Milestone: 1.6b1.6

comment:5 Changed 11 years ago by rdworth

Milestone: 1.71.8

comment:6 Changed 9 years ago by Scott González

Resolution: fixed
Status: newclosed

I can't reproduce these issues and the test pages are no longer being hosted. If you continue to have problems, please open a new ticket with a test case for each individual issue.

Closing fixed as these issues were likely fixed over the past few years.

comment:7 Changed 9 years ago by Scott González

Milestone: 1.91.8.2
Note: See TracTickets for help on using tickets.