Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#2947 closed bug (fixed)

Sortable Throws Errors in Firefox 3 rc1

Reported by: wundbread@… Owned by: paul
Priority: major Milestone: 1.5.1
Component: ui.sortable Version: 1.5
Keywords: Cc:
Blocked by: Blocking:

Description

Sortable applied to nested lists like : $("#main li.opened > ul").sortable({connectWith: $("#main li.opened > ul")});

Error: [Exception... "Node cannot be inserted at the specified point in the hierarchy" code: "3" nsresult: "0x80530003 (NS_ERROR_DOM_HIERARCHY_REQUEST_ERR)" location: "http://localhost/groupy/core/js/jquery/jquery.js Line: 257"] Source File: http://localhost/groupy/core/js/jquery/jquery.js Line: 257

And

Error: [Exception... "Node cannot be inserted at the specified point in the hierarchy" code: "3" nsresult: "0x80530003 (NS_ERROR_DOM_HIERARCHY_REQUEST_ERR)" location: "http://localhost/groupy/core/js/jquery/jquery.js Line: 257"] Source File: http://localhost/groupy/core/js/jquery/jquery.js Line: 251

Wrapping insertBefore calls in try catch eliminates error. In both cases both the elements are LI tags. I tried setting containment, but the errors still occur.

Change History (3)

comment:1 Changed 12 years ago by paul

I cannot reproduce the issue - could you provide a simple test markup for me? Thanks!

comment:2 Changed 12 years ago by paul

Resolution: fixed
Status: newclosed

Should work now!

comment:3 Changed 12 years ago by paul

Milestone: 1.51.5.1
Version: 1.5rc11.5
Note: See TracTickets for help on using tickets.