Opened 12 years ago

Closed 12 years ago

#2970 closed bug (notabug)

dynamic size of droppable region causes much discomfort

Reported by: rcg@… Owned by: paul
Priority: major Milestone: 1.5
Component: ui.droppable Version:
Keywords: dynamic size resize Cc:
Blocked by: Blocking:

Description

On line 33 of ui.droppable.js, the width and height are assigned to this.element.outerWidth() and ...outerHeight(). This caused a bug in my application in which the dimensions of the droppable div change after droppable(...) is called.

You may want to change proportions.width from a variable to a function such as: this.proportions.width = function(){return $(element).outerWidth()}

This will evaluate the width of the droppable appropriately.

Change History (1)

comment:1 Changed 12 years ago by paul

Resolution: invalid
Status: newclosed

This is not a bug, because your proposal would slow down the script a lot. However, you can either set the refreshPositions option in draggables to true, or call the refresh function manually, to correct your issue.

Note: See TracTickets for help on using tickets.