Opened 11 years ago

Closed 11 years ago

#2998 closed bug (worksforme)

Problem with showOn: 'button' in Internet Explorer 6 and 7

Reported by: johann.thorvaldur@… Owned by: grabanski
Priority: major Milestone: 1.5.2
Component: ui.datepicker Version: 1.5
Keywords: datepicker, ie, internet explorer, jquery 1.2.6 Cc:
Blocked by: Blocking:

Description

When using the UI datepicker 1.5. with jquery 1.2.6 I encountered a fatal javascript error in Internet Explorer 6 and 7

--------------------------- Error --------------------------- A Runtime Error has occurred.

Line: 1070 Error: Object doesn't support this action

This line number refers to JQuery 1.2.6, the uncompressed version

  • $Date: 2008-05-24 14:22:17 -0400 (Sat, 24 May 2008) $
  • $Rev: 5685 $

The error occurs when initializing the datepicker with the following code

$(function(){

$('#test_test').datepicker({

maxDate:new Date(9999,12-1, 31), minDate:new Date(1,1-1, 1), showOtherMonths:true, buttonText:'Choose a date', showOn:'button', dateFormat:'dd.mm.yyyy'

});

});

Everything works fine if I remove the showOn option or use JQuery 1.2.3.

Change History (2)

comment:1 Changed 11 years ago by rdworth

Milestone: 1.51.5.2

comment:2 Changed 11 years ago by kbwood

Resolution: worksforme
Status: newclosed

Can't reproduce this with the latest versions in either IE6 or IE7.

Note: See TracTickets for help on using tickets.