Opened 11 years ago

Closed 11 years ago

#3007 closed bug (wontfix)

Click event missing for resizable with proxy

Reported by: JohnnyCee Owned by: eduardo
Priority: critical Milestone: 1.7
Component: ui.resizable Version: 1.5
Keywords: Cc:
Blocked by: Blocking:

Description

I am seeing a difference between click events when dragging verses resizing. The key factor is whether the element uses a proxy as part of resizing. If a proxy is used, the resize operation is not followed by a click event. When a proxy is not used, the resize IS followed by a click event. The test page linked below shows the difference. Two resizable DIVs, one by proxy and one not. Events are listed in a list on the right of the page.

http://www.johncardinal.com/resize/

(The test page was created 14 Jun 2008, and will be around a while but probably not forever.)

I discovered this issue because of a difference between draggable and resizable: as far as I can tell, a draggable will always send three events after a click: start, stop, click. A resizable sends either start, stop, click or just start, stop, as described above.

Change History (6)

comment:1 Changed 11 years ago by rdworth

Milestone: 1.51.5.2

comment:2 Changed 11 years ago by paul

Milestone: 1.5.21.6b

comment:3 Changed 11 years ago by Cloudream

Milestone: 1.6b1.6
Priority: minormajor
Status: newassigned

comment:4 Changed 11 years ago by Jörn Zaefferer

Confirmed, test makes it very clear.

comment:5 Changed 11 years ago by Scott González

Priority: majorcritical

comment:6 Changed 11 years ago by paul

Resolution: wontfix
Status: assignedclosed

This is not a bug, but expected behaviour - since what you are doing on the first example is actually a click - you mousedown and mouseup on the same element (you don't if you use a proxy). Even if we wanted to normalize it, it's hardly possible, technically.

Note: See TracTickets for help on using tickets.