Opened 11 years ago

Closed 11 years ago

#3020 closed bug (duplicate)

IntegrityError: (1062, "Duplicate entry 'kbwood-1-query_constrain' for key 1")

Reported by: kbwood Owned by:
Priority: minor Milestone:
Component: [meta] ui.site Version:
Keywords: Cc:
Blocked by: Blocking:

Description

How to Reproduce

While doing a GET operation on /query, Trac issued an internal error.

IntegrityError: (1062, "Duplicate entry 'kbwood-1-query_constrain' for key 1")

System Information

Trac 0.11rc1
Python 2.4.4 (#2, Apr 26 2007, 00:02:45)
[GCC 4.1.2 20061115 (prerelease) (Debian 4.1.1-21)]
setuptools 0.6c8
MySQL server: "5.0.51a-3-log", client: "5.0.51a", thread-safe: 1
MySQLdb 1.2.2
Genshi 0.4.4
Pygments 0.9
Subversion 1.4.4 (r25188)

Python Traceback

Traceback (most recent call last):
  File "/usr/lib/python2.4/site-packages/Trac-0.11rc1-py2.4.egg/trac/web/main.py", line 417, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/lib/python2.4/site-packages/Trac-0.11rc1-py2.4.egg/trac/web/main.py", line 222, in dispatch
    req.session.save()
  File "/usr/lib/python2.4/site-packages/Trac-0.11rc1-py2.4.egg/trac/web/session.py", line 93, in save
    "VALUES(%s,%s,%s,%s)", attrs)
  File "/usr/lib/python2.4/site-packages/Trac-0.11rc1-py2.4.egg/trac/db/util.py", line 57, in executemany
    return self.cursor.executemany(sql_escape_percent(sql), args)
  File "/usr/lib/python2.4/site-packages/Trac-0.11rc1-py2.4.egg/trac/db/util.py", line 57, in executemany
    return self.cursor.executemany(sql_escape_percent(sql), args)
  File "/var/lib/python-support/python2.4/MySQLdb/cursors.py", line 218, in executemany
    r = self._query('\n'.join([query[:p], ',\n'.join(q), query[e:]]))
  File "/var/lib/python-support/python2.4/MySQLdb/cursors.py", line 312, in _query
    rowcount = self._do_query(q)
  File "/var/lib/python-support/python2.4/MySQLdb/cursors.py", line 276, in _do_query
    db.query(q)
IntegrityError: (1062, "Duplicate entry 'kbwood-1-query_constrain' for key 1")

Change History (3)

comment:1 Changed 11 years ago by paul

Resolution: fixed
Status: newclosed

Should be fine now!

comment:2 Changed 11 years ago by rdworth

Resolution: fixed
Status: closedreopened

comment:3 Changed 11 years ago by rdworth

Component: [meta] ui.themeroller[meta] ui.site
Resolution: duplicate
Status: reopenedclosed

duplicate of #2973

Note: See TracTickets for help on using tickets.