Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#3055 closed bug (wontfix)

hovering elements over other elements while sorting

Reported by: 15steps Owned by: paul
Priority: minor Milestone:
Component: ui.sortable Version: 1.5.1
Keywords: Cc:
Blocked by: Blocking:

Description

While sorting, you can hover one element over another without the bottom element snapping out of the way. This demo is an example:

http://ui.jquery.com/repository/real-world/layout

Being able to hover one element over another isn't the default behavior for similar sortable interfaces. In other sortable interfaces, moving an element into another's space almost immediately moves the other element out of the way, i.e. you can't as easily hover one tile over the other. For examples of other sortable interfaces:

http://www.google.com/ig

http://www.netvibes.com/

http://interface.eyecon.ro/demos/sort.html

Change History (5)

comment:1 Changed 11 years ago by paul

Resolution: wontfix
Status: newclosed

This is not a bug, but a thoughful implementation. However, we've added other tolerance modes for it - For example, tolerance: "pointer."

comment:2 Changed 11 years ago by 15steps

Thanks for the response and advice on how to fix the default so it acts more like other sortable interfaces.

To correct, the option is documented as "distance" not "tolerance."

comment:3 in reply to:  1 Changed 11 years ago by 15steps

Replying to paul:

This is not a bug, but a thoughful implementation. However, we've added other tolerance modes for it - For example, tolerance: "pointer."

I was wrong: setting "distance" to 1 doesn't enable the desired behavior and I don't see "tolerance" as a documented option for sortables (it is documented for draggables). Though not documented, "tolerance: pointer" doesn't enable the desired behavior either. Is there some other option that might be enabled to stop elements from hiding one another?

What reasons are there for allowing sorted elements to hide one another? I'm curious to know why the development team would depart from what seems like standard behavior. If this isn't the place to ask for development rationale, apologies in advance.

comment:4 Changed 11 years ago by paul

I think I don't really understand what you mean by hiding another element...could you maybe post it to the mailing lists? Thanks!

comment:5 in reply to:  4 Changed 11 years ago by 15steps

Replying to paul:

I think I don't really understand what you mean by hiding another element...could you maybe post it to the mailing lists? Thanks!

I posted a message to the mailing list with a screencast here:

http://groups.google.com/group/jquery-ui/browse_thread/thread/736277f7a998df4d/7edc3bb444d8ffe2

Note: See TracTickets for help on using tickets.