Opened 11 years ago

Closed 11 years ago

#3057 closed bug (fixed)

Bug in DatePicker - CustomRange

Reported by: lukebrookhart Owned by: paul
Priority: minor Milestone: 1.7
Component: ui.datepicker Version: 1.5.1
Keywords: customrange Cc: m@…
Blocked by: Blocking:

Description

CustomRange, as found on http://ui.jquery.com/functional_demos/#ui.datepicker under "Another Date Range", does not link the two input selections.

It should not be possible to select a date in the first input that is greater than the date in the second input. Nor should it be possible to select a date in the second input that is less than the date in the first input.

Change History (5)

comment:1 Changed 11 years ago by kbwood

The problem is that the demo contains $("#startDate,#endDate").datepicker({beforeShow: $.datepicker.customRange, ... whereas it should be $("#startDate,#endDate").datepicker({beforeShow: customRange, ... The latter version is what is in SVN, so where does the other version come from?

comment:2 Changed 11 years ago by grabanski

Priority: majorminor

Changing priority to minor since this is not a bug with the datepicker core, but a demo implementation.

comment:3 Changed 11 years ago by Cloudream

Milestone: 1.6

comment:4 Changed 11 years ago by Cloudream

Owner: changed from grabanski to paul
Status: newassigned

comment:5 Changed 11 years ago by paul

Resolution: fixed
Status: assignedclosed
Note: See TracTickets for help on using tickets.