Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#3063 closed bug (fixed)

Binding handler to 'tabsselect': ui undefined

Reported by: acheetham Owned by: klaus.hartl
Priority: major Milestone: 1.5.2
Component: ui.tabs Version: 1.5.1
Keywords: Cc:
Blocked by: Blocking:

Description

In an event handler bound to the "tabsselect" event, the 'ui' parameter is undefined.

To reproduce: Given the example code provided in the UI/Tabs documentation (http://docs.jquery.com/UI/Tabs#Events), bind an event handler to "tabsselect", e.g.

<script> $(document).ready(function(){

var tablist = $("#example > ul").tabs(); tablist.bind("tabsselect", function(evt, ui) {

alert("tab: "+ui.tab);

});

}); </script>

The attempt to access ui.tab will produce an error, because ui is undefined.

Change History (2)

comment:1 Changed 8 years ago by paul

  • Resolution set to fixed
  • Status changed from new to closed

This is a known regression in jQuery UI 1.5.1. In this version, if you bind to the event this way, the third parameter is the UI object. It's fixed in the next release coming out in the next days.

comment:2 Changed 8 years ago by paul

  • Milestone set to 1.5.2
Note: See TracTickets for help on using tickets.