Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#3068 closed bug (duplicate)

IntegrityError: (1062, "Duplicate entry 'jquery@rickster-1-0' for key 1")

Reported by: jquery@… Owned by: paul
Priority: major Milestone:
Component: [meta] ui.site Version:
Keywords: Cc:
Blocked by: Blocking:

Description

How to Reproduce

While doing a GET operation on /report/7, Trac issued an internal error.

see integrity error at bottom of traceback

Request parameters:

{'id': u'7'}

System Information

Trac 0.11rc1
Python 2.4.4 (#2, Apr 26 2007, 00:02:45)
[GCC 4.1.2 20061115 (prerelease) (Debian 4.1.1-21)]
setuptools 0.6c8
MySQL server: "5.0.51a-3-log", client: "5.0.51a", thread-safe: 1
MySQLdb 1.2.2
Genshi 0.4.4
Pygments 0.9
Subversion 1.4.4 (r25188)

Python Traceback

Traceback (most recent call last):
  File "/usr/lib/python2.4/site-packages/Trac-0.11rc1-py2.4.egg/trac/web/main.py", line 417, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/lib/python2.4/site-packages/Trac-0.11rc1-py2.4.egg/trac/web/main.py", line 222, in dispatch
    req.session.save()
  File "/usr/lib/python2.4/site-packages/Trac-0.11rc1-py2.4.egg/trac/web/session.py", line 84, in save
    (self.sid, self.last_visit, authenticated))
  File "/usr/lib/python2.4/site-packages/Trac-0.11rc1-py2.4.egg/trac/db/util.py", line 50, in execute
    return self.cursor.execute(sql_escape_percent(sql), args)
  File "/usr/lib/python2.4/site-packages/Trac-0.11rc1-py2.4.egg/trac/db/util.py", line 50, in execute
    return self.cursor.execute(sql_escape_percent(sql), args)
  File "/var/lib/python-support/python2.4/MySQLdb/cursors.py", line 166, in execute
    self.errorhandler(self, exc, value)
  File "/var/lib/python-support/python2.4/MySQLdb/connections.py", line 35, in defaulterrorhandler
    raise errorclass, errorvalue
IntegrityError: (1062, "Duplicate entry 'jquery@rickster-1-0' for key 1")

Change History (4)

comment:1 Changed 11 years ago by Scott González

Resolution: worksforme
Status: newclosed

comment:2 Changed 11 years ago by rdworth

Resolution: worksforme
Status: closedreopened

comment:3 Changed 11 years ago by rdworth

Resolution: duplicate
Status: reopenedclosed

duplicate of #2973

comment:4 Changed 11 years ago by rdworth

Component: ui.core[meta] ui.site
Note: See TracTickets for help on using tickets.