Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#3076 closed bug (fixed)

Modal dialog not working correctly on Opera 9.51

Reported by: happycow Owned by: scottgonzalez
Priority: minor Milestone: 1.6b
Component: ui.dialog Version: 1.5.1
Keywords: dialog box Cc:
Blocked by: Blocking:

Description

On Firefox, modal dialog works as expected; no other screen elements can be clicked. With Opera, dialog opens, but it is not modal.

See attached HTML for sample code.

Attachments (1)

test.html (1.3 KB) - added by happycow 8 years ago.
Sample HTML file demonstrating problem

Download all attachments as: .zip

Change History (6)

Changed 8 years ago by happycow

Sample HTML file demonstrating problem

comment:1 Changed 8 years ago by paul

  • Owner changed from paul to rdworth
  • Status changed from new to assigned

comment:2 Changed 8 years ago by scottgonzalez

  • Component changed from ui.core to ui.dialog
  • Milestone set to 1.6b
  • Owner changed from rdworth to scott.gonzalez
  • Status changed from assigned to accepted

comment:3 Changed 8 years ago by scottgonzalez

  • Priority changed from major to minor

This is an inaccurate description. The dialog is modal and no other form elements can be interacted with. The problem is that the overlay doesn't fill the entire window if the document is smaller than the window.

comment:4 Changed 8 years ago by scottgonzalez

  • Resolution set to fixed
  • Status changed from accepted to closed

Fixed in [452].

comment:5 Changed 8 years ago by ThrushAAX

I guess that's an OK fix for now... though the real bug is with jQuery itself. http://dev.jquery.com/ticket/3046

Note: See TracTickets for help on using tickets.