Opened 12 years ago

Closed 12 years ago

#3092 closed bug (fixed)

Image cropper demo errors (patch included)

Reported by: andyfowler Owned by: eduardo
Priority: minor Milestone:
Component: [meta] ui.themeroller Version: 1.5.1
Keywords: resizable, imagecropper, cropper Cc:
Blocked by: Blocking:

Description

When using the code provided in the Image Cropper demo, under certain conditions, it can cause errors in the callback functions that are provided. This can happen if the cropper is placed out of bounds, or under other odd circumstances.

The problem is in the code that inverts the values and adjusts the background of the resizable. If a value is already negative, it causes a double negative, and is not parsed.

Fix: replace all instances of

this.style.backgroundPosition = '-' + (self.position.left) + 'px -' + (self.position.top) + 'px';

with

this.style.backgroundPosition = (self.position.left * -1) + 'px ' + (self.position.top * -1) + 'px';

Seems like a more logical way to invert a value, and won't result in a double negative.

Change History (3)

comment:1 Changed 12 years ago by Cloudream

Without mention, this issue seems already has been fixed.

comment:2 Changed 12 years ago by Cloudream

Sorry for last reply, it's for #3040.

This issus has fixed in [508].

comment:3 Changed 12 years ago by Cloudream

Component: ui.resizableui.meta (website, demos)
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.