Opened 12 years ago

Closed 12 years ago

#3093 closed bug (duplicate)

Themeroller Bug in the production of the Theme CSS file for DatePicker

Reported by: nimbusism@… Owned by: grabanski
Priority: minor Milestone:
Component: ui.datepicker Version: 1.5.1
Keywords: Cc:
Blocked by: Blocking:

Description

The application produces the following code when requesting the default theme at the address: http://ui.jquery.com/themeroller

/*datepicker*/
/* Main Style Sheet for jQuery UI date picker */
.ui-datepicker-div, .ui-datepicker-inline {

/*resets*/margin: 0;
padding: 0;
border: 0;
outline: 0;
line-height: 1.3;
text-decoration: none;
font-size: 100%;
list-style: none;
font-family: Verdana, Arial, sans-serif;
background: #ffffff;
font-size: 10px;
border: 4px solid #d3d3d3;
width: 15.5em;
padding: 2.5em .5em .5em .5em;
position: relative;

}

.ui-datepicker-div {


z-index: 9999; /*must have*/
display: none;
background: #ffffff;

}

When viewing the code that jquery produces after attaching the date picker to a text box, the div does not have a class called "ui-datepicker-div" on it and therefore the class is never used on the element, causing the rendered result to be extremely different from the desired result. It does however have "ui-datepicker-div" for an id. I changed the code above to use id selectors instead of class selectors and everything is working well.

Change History (1)

comment:1 Changed 12 years ago by Scott González

Resolution: duplicate
Status: newclosed

Duplicate of #3003.

Note: See TracTickets for help on using tickets.