Opened 12 years ago

Closed 11 years ago

Last modified 7 years ago

#3104 closed bug (wontfix)

Dialog (or draggable) glitch when html tags styled

Reported by: Matro Owned by: paul
Priority: major Milestone:
Component: ui.draggable Version: 1.5.1
Keywords: draggable jump cursor margin Cc:
Blocked by: Blocking:

Description

Conditions: *FF3 (OS X and Win XP) but not IE6 This bug appears with the following CSS: html {

width: 70%; margin: 0 auto;

} but NOT if the same styling is applied to the body element instead.

Bug effect: As soon as the user begins to drag the dialog box, the user's cursor jumps left of the mousedown point by a distance equal to the left margin of the page.

Other effects not confirmed to be related: The size of the popup may end up changing such that it cuts off the right-hand side. I was not able to confirm which layer was causing the clipping.

Change History (4)

comment:1 Changed 11 years ago by Cloudream

Milestone: TDB

comment:2 Changed 11 years ago by Scott González

Component: ui.dialogui.draggable
Keywords: dialog slide removed
Owner: changed from scott.gonzalez to paul

This is most likely due to the fact that the browser reports the X and Y coordinates of the mouse events as if there was no margin on the html.

comment:3 Changed 11 years ago by paul

Resolution: wontfix
Status: newclosed

This is a bug with the offset method in jQuery - it doesn't properly support html/body tags with margins. Can you enter it as a ticket on http://bugs.jquery.com? thanks!

comment:4 Changed 7 years ago by Scott González

Milestone: TBD

Milestone TBD deleted

Note: See TracTickets for help on using tickets.