Opened 8 years ago

Closed 7 years ago

Last modified 7 years ago

#3112 closed bug (fixed)

SwitchClass doesn't have any effect in Safari 3.1.1

Reported by: igor.morozov@… Owned by:
Priority: blocker Milestone: 1.8
Component: ui.effects.core Version: 1.6rc6
Keywords: safari effects Cc:
Blocked by: Blocking:

Description

Neither the demo on http://docs.jquery.com/UI/Effects/switchClass not my own attempts at using the switchClass() method have any effect in Safari. The old class isn't removed and the new class isn't applied.

Change History (11)

comment:1 Changed 8 years ago by paul

  • Component changed from ui.core to effects.core

comment:2 Changed 8 years ago by paul

  • Status changed from new to accepted

comment:3 Changed 8 years ago by Cloudream

  • Milestone set to TDB

comment:4 Changed 7 years ago by dtetto

Could we upgrade this one to "critical"? It really should be addressed before 1.7 final.

comment:5 Changed 7 years ago by scottgonzalez

  • Milestone changed from TBD to 1.6
  • Resolution set to fixed
  • Status changed from accepted to closed

Current docs and current trunk both work for me. Probably fixed sometime in the past seven months.

comment:6 Changed 7 years ago by scottgonzalez

  • Priority changed from major to blocker
  • Resolution fixed deleted
  • Status changed from closed to reopened
  • Version changed from 1.5.1 to 1.6rc6

Wrong browser...

comment:7 Changed 7 years ago by scottgonzalez

  • Owner changed from paul to scott.gonzalez
  • Status changed from reopened to accepted

comment:8 Changed 7 years ago by scottgonzalez

  • Owner scott.gonzalez deleted
  • Status changed from accepted to assigned

comment:9 Changed 7 years ago by scottgonzalez

The problem is in $.ui.effects.animateClass when we get the style object.

comment:10 Changed 7 years ago by scottgonzalez

  • Milestone changed from 1.6 to 1.next

Bumping to 1.next because this is not a regression and the underlying code should be completely refactored, which can't happen this late in the release cycle.

comment:11 Changed 7 years ago by scottgonzalez

  • Milestone changed from 1.next to 1.8
  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed in r3257.

Note: See TracTickets for help on using tickets.