Opened 12 years ago

Closed 12 years ago

#3149 closed bug (duplicate)

modal setting on dialog causes slow input on large pages

Reported by: fontzter Owned by: Scott González
Priority: major Milestone:
Component: ui.dialog Version: 1.5.2
Keywords: modal input slow Cc:
Blocked by: Blocking:

Description

To demonstrate I have pasted code here: http://pastecode.com/?show=m77813fa1

If you run this code, you will see that the modal flag make typing in a textarea (inside a dialog) very slow when modal is true.

Richard's analysis:

I see what the problem is. The modal plugin is binding key and mouse events to all links and inputs, to cancel them (to enforce the modal). It seems it's doing this even for the inputs in the dialog (as your test case demonstrates). I'm not 100% sure, but I think we could safely filter those out.

Change History (2)

comment:1 Changed 12 years ago by Scott González

comment:2 Changed 12 years ago by Scott González

Resolution: duplicate
Status: newclosed

Duplicate of #2807.

Note: See TracTickets for help on using tickets.