Opened 12 years ago

Closed 12 years ago

Last modified 9 years ago

#3178 closed bug (wontfix)

Sortable update callback fires twice if connectWith is on

Reported by: anonymous Owned by: paul
Priority: major Milestone: 1.7
Component: ui.sortable Version: 1.5.2
Keywords: Cc:
Blocked by: Blocking:

Description

The update is fired for both of the containers, the old one and the new one. I'd tend to think most people would only want one update, fired for the container the sortable has been moved to.

if (ui.element[0] === ui.item.parent()[0]) {
// is when we want the callback to happen.
}

Change History (3)

comment:1 Changed 12 years ago by ajpiano

I meant to be logged in when I filed this. Oops.

comment:2 Changed 12 years ago by paul

Resolution: wontfix
Status: newclosed

That is not a bug. I if you only want one callback, you can use the "receive" callback.

comment:3 Changed 9 years ago by Phil True

This is too a bug. I have two lists that are sortable and they are connnected. I need to be able to handle the intra-list changes as well as the inter-list changes. I would only expect to see update fired once.

Note: See TracTickets for help on using tickets.