Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#3218 closed enhancement (duplicate)

dialog should be able to determine size itself

Reported by: wichert Owned by: Scott González
Priority: minor Milestone: 1.7
Component: ui.dialog Version: 1.5.2
Keywords: Cc:
Blocked by: Blocking:

Description

dialog() currently hardcodes the size of the dialog. This is rarely what you want. At least there should be an option to determine the size automatically.

Change History (4)

comment:1 Changed 11 years ago by Cloudream

Resolution: duplicate
Status: newclosed

comment:2 Changed 11 years ago by Cloudream

Milestone: TDB1.6

comment:3 Changed 11 years ago by wichert

I do not see how #3190 is a duplicate of this bugreport.

I am currently using a modified version of ui.dialog which does not set the height and width CSS values at all if the width and height options are undefined, leaving the sizing. completely up to the browser and this works perfectly in FF3, Safari and IE. I would like to have a similar option using the standard ui.dialog as well, having a local fork is not ideal.

comment:4 Changed 11 years ago by ThrushAAX

huh? ui.dialog does not hard code the height/width of the dialog container. Instead you set it as an option, its default is $("#dialog").dialog({height:200,width:300})

Doing .dialog({height:,width:}) should work fine. You could also calculate the dimensions based off of the contents size.

Note: See TracTickets for help on using tickets.