Opened 11 years ago

Closed 11 years ago

Last modified 7 years ago

#3515 closed bug (fixed)

DatePicker broken by ID with period

Reported by: andersonic Owned by: grabanski
Priority: major Milestone:
Component: ui.datepicker Version: 1.5.2
Keywords: spring Cc:
Blocked by: Blocking:

Description

If the text input has an ID with a period (.) in it, such as

<input type="text" class="datePicker" id="user.startDate" />

the date picker will not set the value when a number is clicked. You get the error "elem is undefined" for

var id = elem[ expando ]

at jquery-1.2.6.js (line 662).

It appears the problem is that the period confuses the selector for returning to the element. Changing the ID to not have a period fixes the problem, but period-delimited input IDs are central to the Spring framework, so this can't always be worked around.

Change History (3)

comment:1 Changed 11 years ago by andersonic

Should have specified this was with Firefox 3.03

comment:2 Changed 11 years ago by kbwood

Resolution: fixed
Status: newclosed

Already fixed in 1.6.

comment:3 Changed 7 years ago by Scott González

Milestone: TBD

Milestone TBD deleted

Note: See TracTickets for help on using tickets.