Opened 10 years ago

Closed 10 years ago

Last modified 6 years ago

#3518 closed bug (worksforme)

Date picker error when the text box's id=1

Reported by: crackerizer Owned by: grabanski
Priority: minor Milestone:
Component: ui.datepicker Version: 1.6rc2
Keywords: Cc:
Blocked by: Blocking:

Description

I use the text box id to store an information(id of database). When the id="1", the following error(dump from opera) occurs:

JavaScript - http://football/index.php?q=football/match Event thread: click Error: name: TypeError message: Statement on line 1172: Cannot convert undefined or null to Object Backtrace:

Line 1172 of linked script http://football/sites/all/modules/football/js/ui.datepicker.js?w

return inst.settings[name] !== undefined ?

Line 765 of linked script http://football/sites/all/modules/football/js/ui.datepicker.js?w

var rangeSelect = this._get(inst, 'rangeSelect');

Line 1 of function script

jQuery.datepicker._selectDay('#1',9,2008, this);

...

stacktrace: n/a; see 'opera:config#UserPrefs|Exceptions Have Stacktrace'

The same error is also apply to firefox 3 and internet explorer 6. The others id are working fine.

Change History (2)

comment:1 Changed 10 years ago by kbwood

Resolution: worksforme
Status: newclosed

Unable to reproduce this problem in FF3, FF2, IE7, IE6.

The HTML and XHTML specifications state that an ID should start with a letter.

comment:2 Changed 6 years ago by Scott González

Milestone: TBD

Milestone TBD deleted

Note: See TracTickets for help on using tickets.