Opened 7 years ago

Closed 7 years ago

#3545 closed bug (fixed)

Error when dragging an item before last item has finished dragging

Reported by: Jo-W Owned by: paul
Priority: major Milestone: 1.7
Component: ui.sortable Version: 1.6rc2
Keywords: Cc:
Blocked by: Blocking:


Firefox 3.0, JQuery 1.2.6, JQuery UI 1.6rc2

If I drag an item in a sortable list and begin dragging another item before the previous one has completed dropping: javascript errors occur, the place holder is not removed, the first element dragged remains absolutely positioned.

This is especially apparent when revert is on, however I have been able to reproduce it with revert off.

Steps to reproduce 1) See my attached testcase 2) Drag items around fast enough so that the animation does not finish before dragging the second time

Attachments (1)

testcase.html (1008 bytes) - added by Jo-W 7 years ago.
UI Sortable testcase, requires jquery.js and jquery.ui.js

Download all attachments as: .zip

Change History (3)

Changed 7 years ago by Jo-W

UI Sortable testcase, requires jquery.js and jquery.ui.js

comment:1 Changed 7 years ago by scott.gonzalez

  • Milestone changed from TBD to 1.6

comment:2 Changed 7 years ago by paul

  • Resolution set to fixed
  • Status changed from new to closed

After testing it thoroughly, this issue seems to be fixed in the latest version.

Note: See TracTickets for help on using tickets.