Opened 7 years ago

Closed 7 years ago

#3552 closed bug (fixed)

document elements can't retrieve mouse down/up event when dragging layer

Reported by: mark.leung Owned by: paul
Priority: critical Milestone: 1.7
Component: ui.core Version: 1.5.2
Keywords: mouse event bubble Cc:
Blocked by: Blocking:

Description

Summmary: When using draggable plugin to enable the dragging feature on the layer, at the moment of dragging layer, the elements which register on document and listen to the mouse down event will not work.

Problem Desc: http://groups.google.com/group/jquery-ui/browse_thread/thread/61297f6c2504eac9?hl=en

Root Cause: The function mouseDown/mouseUp/mouseMove at the file ui.core.js will always return false, and then jQuery will stop the mouse event bubbling, that the elements register on document and listen to the mouse event will not works.

Impact: All elements handlers which rely on the mouse down/up event will not work.

Attachments (1)

nested-mouse.patch (962 bytes) - added by scottgonzalez 7 years ago.

Download all attachments as: .zip

Change History (5)

comment:1 Changed 7 years ago by scottgonzalez

  • Milestone changed from TBD to 1.6

comment:2 Changed 7 years ago by paul

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in r1000.

comment:3 Changed 7 years ago by scottgonzalez

  • Resolution fixed deleted
  • Status changed from closed to reopened

Reintroduced in r1763.

Changed 7 years ago by scottgonzalez

comment:4 Changed 7 years ago by scottgonzalez

  • Resolution set to fixed
  • Status changed from reopened to closed

Fixed in r1818.

Note: See TracTickets for help on using tickets.