Opened 11 years ago

Closed 11 years ago

Last modified 7 years ago

#3600 closed bug (notabug)

Preloading of tabs broke at r864

Reported by: skorpan Owned by: klaus.hartl
Priority: major Milestone:
Component: ui.tabs Version: 1.6rc2
Keywords: tabs, settimeout, 10053, software, caused, connection, abort Cc:
Blocked by: Blocking:

Description

When I use revision 861 of ui.tabs preloading of tabs works perfectly well, but when I use the next version of it (revision 864) my server breaks. The problem occurs both in IE7 and FF3, but I haven't tested it in other browsers.

The comment for revision 864 is: "UI Tabs: fixed tabs select causing page to jump bug, removed cruft form former history integration which will work differently anyway"

I'm using Django. Using Lighttpd with FastCGI, I get this error: 2008-11-18 11:55:59: (connections.c.344) connection closed - read failed: Software caused connection abort 113

Using Django's development server, I get this version: error: (10053, 'Software caused connection abort')

The strange thing is that this problem doesn't occur when I use setTimeout with a long enough delay, i.e. something like setTimeout(function () { tabs.tabs('load', 1); }, 200);. I'd doubt that this is a problem caused by Django, since it has been tested and used by a vast amount of different web sites and because it uses Python's socket.py which is even further tested.

I will attach the code I'm testing this with, it's very short.

Attachments (2)

test.js (139 bytes) - added by skorpan 11 years ago.
The JavaScript for the test.
test.html (848 bytes) - added by skorpan 11 years ago.
The HTML for the test.

Download all attachments as: .zip

Change History (4)

Changed 11 years ago by skorpan

Attachment: test.js added

The JavaScript for the test.

Changed 11 years ago by skorpan

Attachment: test.html added

The HTML for the test.

comment:1 Changed 11 years ago by klaus.hartl

Resolution: invalid
Status: newclosed

I have my doubts that this can be caused by the plugin. Serving up with Apache as a quick test does not give me an error.

comment:2 Changed 7 years ago by Scott González

Milestone: TBD

Milestone TBD deleted

Note: See TracTickets for help on using tickets.