Opened 13 years ago

Closed 11 years ago

Last modified 11 years ago

#3611 closed bug (fixed)

Animation clears radio button's CHECKED attribute in IE

Reported by: brostbeef Owned by:
Priority: major Milestone: 1.5.2
Component: ui.effects.core Version: 1.5.2
Keywords: radio button Cc:
Blocked by: Blocking:

Description

I have a <DIV> container which contains radio buttons. When I toggle/show/hide that container with options, the radio buttons are cleared in IE, but not in Firefox.

Example of what works: $('#lp_del').click( function () {

$('#sp_ded').toggle( );

});

Example of what doesn't: $('#lp_del').click( function () {

$('#sp_ded').toggle( "blind", { direction: "horizontal" }, 500 );

});

The <DIV> container sp_ded hides, but before it does, the CHECKED radio button is first unchecked. When container reappears, the radio button is still unchecked. However, in Firefox, the container remains checked all the way through.

Remember, the radio button is left alone if no options are given for toggle/show/hide, but unchecked when options are given.

Change History (6)

comment:1 Changed 13 years ago by Jörn Zaefferer

Resolution: invalid
Status: newclosed

Invalid, not related to jQuery UI. Use the jQuery bugtracker instead: http://dev.jquery.com/newticket

comment:2 Changed 13 years ago by Jörn Zaefferer

Milestone: TBD1.6
Resolution: invalid
Status: closedreopened

Whoops, nevermind.

comment:3 Changed 13 years ago by rdworth

Milestone: 1.71.8

comment:4 Changed 11 years ago by Corey Frang

http://jsfiddle.net/eGgvw/6/ -- This is an issue with .wrap() etc in Core...

See: http://bugs.jquery.com/ticket/8060#comment:16 for the jQuery bug and a pull request

For history sake, http://bugs.jquery.com/ticket/8500 is a duplicate of 8060, but some good discussion here.

Last edited 11 years ago by Corey Frang (previous) (diff)

comment:5 Changed 11 years ago by Corey Frang

Resolution: fixed
Status: reopenedclosed

comment:6 Changed 11 years ago by Scott González

Milestone: 1.91.5.2
Note: See TracTickets for help on using tickets.